<!DOCTYPE html>
<html lang="en-US"
      prefix="og: http://ogp.me/ns#">
<head>
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1">
  <link rel="profile" href="http://gmpg.org/xfn/11">
  <script src="http://code.jquery.com/jquery-1.11.2.min.js" type="text/javascript"></script>
              <script type="text/javascript"> var epic_ajax_url = 'https://yovenice.com/?epic-ajax-request=epic-ne'; </script>
            
	<!-- This site is optimized with the Yoast SEO plugin v15.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Venice Family Clinic Honors Outgoing CEO Elizabeth Benson Forer at Power of Us Event - Yo! Venice!</title>
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Venice Family Clinic Honors Outgoing CEO Elizabeth Benson Forer at Power of Us Event - Yo! Venice!" />
	<meta property="og:description" content="October 23 Celebration featured Billy Gardell, Folake Olowofoyeku, Gina Yashere and more Venice Family Clinic, a nonprofit community health center..." />
	<meta property="og:url" content="https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/" />
	<meta property="og:site_name" content="Yo! Venice!" />
	<meta property="article:publisher" content="https://www.facebook.com/YoVenice/" />
	<meta property="article:published_time" content="2022-10-26T11:38:18+00:00" />
	<meta property="article:modified_time" content="2022-10-26T11:38:19+00:00" />
	<meta property="og:image" content="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-scaled.jpg" />
	<meta property="og:image:width" content="2560" />
	<meta property="og:image:height" content="1707" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@YoVenice" />
	<meta name="twitter:site" content="@YoVenice" />
	<meta name="twitter:label1" value="Written by">
	<meta name="twitter:data1" value="Yo Venice Staff">
	<meta name="twitter:label2" value="Est. reading time">
	<meta name="twitter:data2" value="2 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://yovenice.com/#organization","name":"Yo! Venice!","url":"https://yovenice.com/","sameAs":["https://www.facebook.com/YoVenice/","https://twitter.com/YoVenice"],"logo":{"@type":"ImageObject","@id":"https://yovenice.com/#logo","inLanguage":"en-US","url":"https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2019/08/yo_venice.png","width":200,"height":200,"caption":"Yo! Venice!"},"image":{"@id":"https://yovenice.com/#logo"}},{"@type":"WebSite","@id":"https://yovenice.com/#website","url":"https://yovenice.com/","name":"Yo! Venice!","description":"#1 Local News, Forum, Information and Event Source for Venice Beach, California.","publisher":{"@id":"https://yovenice.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://yovenice.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/#primaryimage","inLanguage":"en-US","url":"https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-scaled.jpg","width":2560,"height":1707,"caption":"CULVER CITY, CA - OCTOBER 23: Chuck Lorre, Gina Yashere, Liz Forer, Billy Gardell and Folake Olowofoyeku attend Venice Family Clinic Power of Us Event at Sony Pictures Studios on October 23, 2022 in Culver City, CA. (Photo by David Crotty/PMC/PMC) *** Local Caption *** Chuck Lorre;Gina Yashere;Liz Forer;Billy Gardell;Folake Olowofoyeku"},{"@type":"WebPage","@id":"https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/#webpage","url":"https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/","name":"Venice Family Clinic Honors Outgoing CEO Elizabeth Benson Forer at Power of Us Event - Yo! Venice!","isPartOf":{"@id":"https://yovenice.com/#website"},"primaryImageOfPage":{"@id":"https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/#primaryimage"},"datePublished":"2022-10-26T11:38:18+00:00","dateModified":"2022-10-26T11:38:19+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/"]}]},{"@type":"Article","@id":"https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/#article","isPartOf":{"@id":"https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/#webpage"},"author":{"@id":"https://yovenice.com/#/schema/person/9a517b43265adcac22d92d0333e972a5"},"headline":"Venice Family Clinic Honors Outgoing CEO Elizabeth Benson Forer at Power of Us Event","datePublished":"2022-10-26T11:38:18+00:00","dateModified":"2022-10-26T11:38:19+00:00","mainEntityOfPage":{"@id":"https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/#webpage"},"publisher":{"@id":"https://yovenice.com/#organization"},"image":{"@id":"https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/#primaryimage"},"articleSection":"News,Upbeat Beat","inLanguage":"en-US"},{"@type":"Person","@id":"https://yovenice.com/#/schema/person/9a517b43265adcac22d92d0333e972a5","name":"Yo Venice Staff","image":{"@type":"ImageObject","@id":"https://yovenice.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/0943cef41cf3deb58ed84f13b0e97bb4?s=96&d=mm&r=r","caption":"Yo Venice Staff"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Yo! Venice! &raquo; Feed" href="https://yovenice.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Yo! Venice! &raquo; Comments Feed" href="https://yovenice.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Yo! Venice! &raquo; Venice Family Clinic Honors Outgoing CEO Elizabeth Benson Forer at Power of Us Event Comments Feed" href="https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/feed/" />
      <!-- facebook -->
      <meta property="og:type" content="article"/>
      <meta property="og:title" content="Venice Family Clinic Honors Outgoing CEO Elizabeth Benson Forer at Power of Us Event"/>
      <meta property="og:description" content="October 23 Celebration featured Billy Gardell, Folake Olowofoyeku, Gina Yashere and more Venice Family Clinic, a nonprofit community health center..."/>
      <meta property="og:url" content="https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/"/>
      <meta property="og:image" content="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-1024x683.jpg"/>
      <meta property="og:site_name" content="Yo! Venice!"/>
      <!-- twitter -->
      <meta name="twitter:card" content="summary" />
      <meta name="twitter:title" content="Venice Family Clinic Honors Outgoing CEO Elizabeth Benson Forer at Power of Us Event" />
      <meta name="twitter:description" content="October 23 Celebration featured Billy Gardell, Folake Olowofoyeku, Gina Yashere and more Venice Family Clinic, a nonprofit community health center..." />
      <meta name="twitter:url" content="https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/" />
      <meta name="twitter:image" content="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-1024x683.jpg" />
    		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/yovenice.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=99f6140c6ee020f39af35c3d1228b9e8"}};
			/*! This file is auto-generated */
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='smls-frontend-style-css'  href='https://yovenice.com/wp-content/plugins/smart-logo-showcase-lite/css/smls-frontend-style.css?ver=1.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='smls-block-editor-css'  href='https://yovenice.com/wp-content/plugins/smart-logo-showcase-lite/inc/smls-block/smls-block.css?ver=1.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://yovenice.com/wp-includes/css/dist/block-library/style.min.css?ver=99f6140c6ee020f39af35c3d1228b9e8' type='text/css' media='all' />
<link rel='stylesheet' id='smls-fontawesome-style-css'  href='https://yovenice.com/wp-content/plugins/smart-logo-showcase-lite/css/font-awesome.min.css?ver=1.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C300%2C600%2C700%2C800&#038;ver=99f6140c6ee020f39af35c3d1228b9e8' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-roboto-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A400%2C300italic%2C400italic%2C500%2C500italic%2C700%2C700italic%2C900italic%2C900&#038;ver=99f6140c6ee020f39af35c3d1228b9e8' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-lato-css'  href='https://fonts.googleapis.com/css?family=Lato%3A400%2C300italic%2C400italic%2C700%2C700italic%2C900italic%2C900&#038;ver=99f6140c6ee020f39af35c3d1228b9e8' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-montserrat-css'  href='https://fonts.googleapis.com/css?family=Montserrat%3A400%2C700&#038;ver=99f6140c6ee020f39af35c3d1228b9e8' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-merriweather-css'  href='https://fonts.googleapis.com/css?family=Merriweather+Sans%3A300%2C400%2C700%2C800+Sans%3A300%2C400%2C700&#038;ver=99f6140c6ee020f39af35c3d1228b9e8' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-droid-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3A400%2C700&#038;ver=99f6140c6ee020f39af35c3d1228b9e8' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-oxygen-css'  href='https://fonts.googleapis.com/css?family=Oxygen%3A300%2C400%2C700&#038;ver=99f6140c6ee020f39af35c3d1228b9e8' type='text/css' media='all' />
<link rel='stylesheet' id='smls-google-fonts-raleway-css'  href='https://fonts.googleapis.com/css?family=Raleway%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900&#038;ver=99f6140c6ee020f39af35c3d1228b9e8' type='text/css' media='all' />
<link rel='stylesheet' id='smls-owl-style-css'  href='https://yovenice.com/wp-content/plugins/smart-logo-showcase-lite/css/owl.carousel.css?ver=1.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='smls-tooltip-style-css'  href='https://yovenice.com/wp-content/plugins/smart-logo-showcase-lite/css/tooltipster.bundle.css?ver=1.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='smls-responsive-style-css'  href='https://yovenice.com/wp-content/plugins/smart-logo-showcase-lite/css/smls-responsive.css?ver=1.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='smls-popup-style-css'  href='https://yovenice.com/wp-content/plugins/smart-logo-showcase-lite/css/popup-contact.css?ver=1.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='balaton-weart-fonts-css'  href='https://fonts.googleapis.com/css?family=Playfair+Display%3A700%7CMontserrat%3A600%2C800%7CLora%3A400%2C400i%2C700%2C700i&#038;subset' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-free-css'  href='https://yovenice.com/wp-content/themes/balaton/assets/fontawesome/css/all.css' type='text/css' media='all' />
<link rel='stylesheet' id='balaton-weart-min-css'  href='https://yovenice.com/wp-content/themes/balaton/assets/weart.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='balaton-style-css'  href='https://yovenice.com/wp-content/themes/balaton/style.css?ver=99f6140c6ee020f39af35c3d1228b9e8' type='text/css' media='all' />
<link rel='stylesheet' id='main-style-css'  href='https://yovenice.com/wp-content/themes/balaton/style.css?ver=99f6140c6ee020f39af35c3d1228b9e8' type='text/css' media='all' />
<style id='main-style-inline-css' type='text/css'>

          ::selection { background: #fd930a  !important }
          .article-inner:before{ background: linear-gradient(135deg, rgba(255, 255, 255, 0) 0%, #fd930a 100%) }
          .c-1, .l-1 a, .lh-1 a:hover, #weart_balaton_theme a:hover, .btn-outline-dark, .woocommerce .sidebar .button, .woocommerce-page .sidebar .button,.carousel-indicators li.active .title,
          .sidebar .box .sidebar-title *,
          .main .carousel-indicators li.active .title { color: #fd930a !important }

          .woocommerce ul.products li.product span.onsale, .woocommerce-page ul.products li.product span.onsale,
          .woocommerce div.product span.onsale, .woocommerce-page div.product span.onsale,
          .woocommerce div.product form.cart button.button, .woocommerce-page div.product form.cart button.button,
          .woocommerce .sidebar .widget_price_filter .price_slider_wrapper .ui-slider-range, .woocommerce-page .sidebar .widget_price_filter .price_slider_wrapper .ui-slider-range,
          .woocommerce .wc-proceed-to-checkout a.checkout-button,
          .woocommerce .wc-proceed-to-checkout a.checkout-button:hover, .woocommerce-page .wc-proceed-to-checkout a.checkout-button,
          .woocommerce-page .wc-proceed-to-checkout a.checkout-button:hover,
          .woocommerce .place-order .button.alt,
          .woocommerce .place-order .button.alt:hover, .woocommerce .wc-proceed-to-checkout .button.alt,
          .woocommerce .wc-proceed-to-checkout .button.alt:hover, .woocommerce-page .place-order .button.alt,
          .woocommerce-page .place-order .button.alt:hover, .woocommerce-page .wc-proceed-to-checkout .button.alt,
          .woocommerce-page .wc-proceed-to-checkout .button.alt:hover ,
          .bg-1 { background-color: #fd930a !important }

          .brd-1, .woocommerce .woocommerce-info, .woocommerce .woocommerce-notice, .woocommerce-page .woocommerce-info, .woocommerce-page .woocommerce-notice{ border-color: #fd930a !important }
                    

          .woocommerce .woocommerce-pagination .page-numbers li .current, .woocommerce-page .woocommerce-pagination .page-numbers li .current,
          .woocommerce ul.products li.product .price, .woocommerce-page ul.products li.product .price,
          .woocommerce div.product p.price, .woocommerce-page div.product p.price,
          .c-black, .l-black a{ color: #080808 !important; }

          .bg-black, .article-content .post-password-form input[type=submit], .bgh-black:hover,
          .woocommerce .sidebar .widget_price_filter .price_slider_wrapper .ui-slider-handle, .woocommerce-page .sidebar .widget_price_filter .price_slider_wrapper .ui-slider-handle,
          .carousel-indicators li.active,
          .bg:after { background-color: #080808 !important; }

          .brd-black,
          .sidebar-title{border-color: #080808 !important;}

          .main .carousel-indicators li.active:after{ border-color: transparent transparent #080808 transparent; }
                    

          ::selection { color: #ffffff; }

          .article-content figure .img-caption, .article-content img .img-caption,
          .woocommerce .place-order .button.alt,
          .woocommerce .place-order .button.alt:hover, .woocommerce .wc-proceed-to-checkout .button.alt,
          .woocommerce .wc-proceed-to-checkout .button.alt:hover, .woocommerce-page .place-order .button.alt,
          .woocommerce-page .place-order .button.alt:hover, .woocommerce-page .wc-proceed-to-checkout .button.alt,
          .woocommerce-page .wc-proceed-to-checkout .button.alt:hover,
          .c-white, .article-content .post-password-form input[type=submit], .l-white a, .lh-white a:hover { color: #FFFFFF !important; }

          .video .carousel-indicators li.active,
          .bg-white { background-color: #FFFFFF !important; }

          .video .carousel-indicators li.active:after { border-color: transparent #FFFFFF transparent transparent; }
                    

          .c-text, .l-text a, .btn-outline-dark:hover, .woocommerce .sidebar .button:hover, .woocommerce-page .sidebar .button:hover{ color: #222222 !important; }

                    
</style>
<link rel='stylesheet' id='epic-icon-css'  href='https://yovenice.com/wp-content/plugins/epic-news-element/assets/fonts/jegicon/jegicon.css?ver=99f6140c6ee020f39af35c3d1228b9e8' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://yovenice.com/wp-content/plugins/epic-news-element/assets/fonts/font-awesome/font-awesome.css?ver=99f6140c6ee020f39af35c3d1228b9e8' type='text/css' media='all' />
<link rel='stylesheet' id='epic-style-css'  href='https://yovenice.com/wp-content/plugins/epic-news-element/assets/css/style.min.css?ver=99f6140c6ee020f39af35c3d1228b9e8' type='text/css' media='all' />
<script type='text/javascript' src='https://yovenice.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://yovenice.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://yovenice.com/wp-content/plugins/smart-logo-showcase-lite/js/owl.carousel.js?ver=1.1.7'></script>
<script type='text/javascript' src='https://yovenice.com/wp-content/plugins/smart-logo-showcase-lite/js/tooltipster.bundle.js?ver=1.1.7'></script>
<script type='text/javascript' src='https://yovenice.com/wp-content/plugins/smart-logo-showcase-lite/js/smls-frontend-script.js?ver=1.1.7'></script>
<link rel='https://api.w.org/' href='https://yovenice.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://yovenice.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://yovenice.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://yovenice.com/?p=44736' />
<link rel="alternate" type="application/json+oembed" href="https://yovenice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fyovenice.com%2F2022%2F10%2F26%2Fvenice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://yovenice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fyovenice.com%2F2022%2F10%2F26%2Fvenice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event%2F&#038;format=xml" />
<!-- start Simple Custom CSS and JS -->
<!-- Adsense/DFP default header -->
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
googletag.cmd.push(function() {

    //here you create a var to map your sizes for this unit - mine is equal in addSizes but you can create how many you need and with different sizes you like. First [992, 0] is for resolution and later [728, 90] is the banner size to this resolution (you can put more than one size for each resolution if you like)
    var mapping = googletag.sizeMapping().

    addSize([1000, 0], [728, 90]).
    addSize([320, 0], [320, 50]).build();

    googletag.defineSlot('/21621973880/yovenice_homepage_leaderboard', [320, 50], 'div-gpt-ad-1598566942528-0').defineSizeMapping(mapping).addService(googletag.pubads());
	googletag.defineSlot('/21621973880/yovenice_homepage_leaderboard_2', [320, 50], 'div-gpt-ad-1598567087088-0').defineSizeMapping(mapping).addService(googletag.pubads());
	googletag.defineSlot('/21621973880/yovenice_homepage_leaderboard_3', [320, 50], 'div-gpt-ad-1598567162394-0').defineSizeMapping(mapping).addService(googletag.pubads());
	googletag.defineSlot('/21621973880/yovenice_footertop', [320, 50], 'div-gpt-ad-1598567470772-0').defineSizeMapping(mapping).addService(googletag.pubads());
	googletag.defineSlot('/21621973880/yovenice_headerleaderboard', [320, 50], 'div-gpt-ad-1598567356379-0').defineSizeMapping(mapping).addService(googletag.pubads());
  	
	googletag.defineSlot('/21621973880/yovenice_articlebottom', [320, 50], 'div-gpt-ad-1598567550570-0').defineSizeMapping(mapping).addService(googletag.pubads());
	googletag.defineSlot('/21621973880/yovenice_article_related_posts_2', [320, 50], 'div-gpt-ad-1598567674224-0').defineSizeMapping(mapping).addService(googletag.pubads());
	googletag.defineSlot('/21621973880/yovenice_article_related_posts_3', [320, 50], 'div-gpt-ad-1598567724154-0').defineSizeMapping(mapping).addService(googletag.pubads());
	googletag.defineSlot('/21621973880/smmirror_articleinline', [320, 50], 'div-gpt-ad-1598293314668-0').defineSizeMapping(mapping).addService(googletag.pubads());
  	
	googletag.defineSlot('/21621973880/yovenice_above_latest_news', [320, 50], 'div-gpt-ad-1596071060207-0').defineSizeMapping(mapping).addService(googletag.pubads());
  
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();

});
</script>

<!-- end Simple Custom CSS and JS -->
<!-- start Simple Custom CSS and JS -->
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2762983-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-2762983-1');
</script>

<!-- end Simple Custom CSS and JS -->

<script type="text/javascript" src='//yovenice.com/wp-content/uploads/custom-css-js/36870.js?v=6504'></script>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #f5f5f5; }
</style>
	<style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css"></style>		<style type="text/css" id="wp-custom-css">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</style>
		<style id="tt-easy-google-font-styles" type="text/css">p { }
h1 { }
h2 { }
h3 { }
h4 { }
h5 { }
h6 { }
.f-meta,.article-content .post-password-form input[type=submit],.woocommerce .woocommerce-result-count,.woocommerce-page .woocommerce-result-count,.woocommerce .orderby,.woocommerce-page .orderby,.woocommerce .woocommerce-pagination .page-numbers,.woocommerce-page .woocommerce-pagination .page-numbers,.woocommerce ul.products li.product .price,.woocommerce-page ul.products li.product .price,.woocommerce div.product form.cart input.qty,.woocommerce-page div.product form.cart input.qty,.woocommerce div.product form.cart button.button,.woocommerce-page div.product form.cart button.button,.woocommerce div.product .woocommerce-tabs ul.tabs li,.woocommerce div.product .related ul.tabs li,.woocommerce-page div.product .woocommerce-tabs ul.tabs li,.woocommerce-page div.product .related ul.tabs li,.woocommerce .sidebar .mini_cart_item,.woocommerce .sidebar ul.product-categories,.woocommerce-page .sidebar .mini_cart_item,.woocommerce-page .sidebar ul.product-categories,.woocommerce .sidebar .woocommerce ul.cart_list li .amount,.woocommerce .sidebar .woocommerce ul.cart_list li .quantity,.woocommerce .sidebar .woocommerce ul.product_list_widget li .amount,.woocommerce .sidebar .woocommerce ul.product_list_widget li .quantity,.woocommerce-page .sidebar .woocommerce ul.cart_list li .amount,.woocommerce-page .sidebar .woocommerce ul.cart_list li .quantity,.woocommerce-page .sidebar .woocommerce ul.product_list_widget li .amount,.woocommerce-page .sidebar .woocommerce ul.product_list_widget li .quantity,.woocommerce .sidebar .woocommerce-mini-cart__total,.woocommerce-page .sidebar .woocommerce-mini-cart__total,.woocommerce .place-order .button.alt,.woocommerce .place-order .button.alt:hover,.woocommerce .wc-proceed-to-checkout .button.alt,.woocommerce .wc-proceed-to-checkout .button.alt:hover,.woocommerce-page .place-order .button.alt,.woocommerce-page .place-order .button.alt:hover,.woocommerce-page .wc-proceed-to-checkout .button.alt,.woocommerce-page .wc-proceed-to-checkout .button.alt:hover,.f-meta-nosize,.sidebar .widget_tag_cloud a,#weart-comments .comment-list .comment .comment-meta,.woocommerce ul.products li.product span.onsale,.woocommerce-page ul.products li.product span.onsale,.woocommerce div.product span.onsale,.woocommerce-page div.product span.onsale,.woocommerce div.product p.price,.woocommerce-page div.product p.price,.woocommerce .sidebar .button,.woocommerce-page .sidebar .button,.woocommerce .wc-proceed-to-checkout a.checkout-button,.woocommerce .wc-proceed-to-checkout a.checkout-button:hover,.woocommerce-page .wc-proceed-to-checkout a.checkout-button,.woocommerce-page .wc-proceed-to-checkout a.checkout-button:hover { }
.f-text,#weart-comments .comment-list .comment,.article-content #review li,.woocommerce .woocommerce-info,.woocommerce .woocommerce-notice,.woocommerce-page .woocommerce-info,.woocommerce-page .woocommerce-notice { }
.f-title,h1,.h1,h2,.h2,h3,.h3,h4,.h4,h5,.h5,.article-content #review .review-summary-title,.article-content #review .review-title,.woocommerce div.product .woocommerce-tabs h2,.woocommerce div.product .related h2,.woocommerce-page div.product .woocommerce-tabs h2,.woocommerce-page div.product .related h2,h6,.h6,.woocommerce ul.products li.product .woocommerce-loop-product__title,.woocommerce-page ul.products li.product .woocommerce-loop-product__title,.article-title,.single header .lead::first-letter,.single header .article-content blockquote p::first-letter,.article-content blockquote .single header p::first-letter,.article-content #review .review-summary-title,.article-content #review .review-title,.woocommerce .sidebar .woocommerce ul.cart_list li a,.woocommerce .sidebar .woocommerce ul.product_list_widget li a,.woocommerce-page .sidebar .woocommerce ul.cart_list li a,.woocommerce-page .sidebar .woocommerce ul.product_list_widget li a { }
</style></head>
<body  class="post-template-default single single-post postid-44736 single-format-standard custom-background wp-custom-logo epic-gutenberg">
  <div class="px-lg-5 py-3" id="weart_balaton_theme">
    <div class="bg-white p-lg-5 shadow mw-weart">
<!-- mobile -->
  <div id="weart-mobile">
    <div class="inner bg-white l-black c-black f-meta text-uppercase">
      <a href="#close" class="fas fa-times bars"></a>
      <!-- menu -->
        <div class="w-menu"><ul id="menu-main" class="menu"><li id="menu-item-35481" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35481"><a href="/">Home</a></li>
<li id="menu-item-35750" class="weart-megamenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35750"><a href="https://yovenice.com/category/venice-beach-opinion/">Opinion</a></li>
<li id="menu-item-35749" class="weart-megamenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35749"><a href="https://yovenice.com/category/venice-beach-health/">Health</a></li>
<li id="menu-item-44187" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44187"><a href="https://yovenice.com/2022-back-to-school-guide/">2022 Back to School Guide</a></li>
<li id="menu-item-38070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38070"><a target="_blank" rel="noopener noreferrer" href="https://mirrormediagroupla.com/">Advertising</a></li>
<li id="menu-item-38071" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38071"><a target="_blank" rel="noopener noreferrer" href="https://mirrormediagroupla.com/">PR Services</a></li>
<li id="menu-item-38072" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38072"><a target="_blank" rel="noopener noreferrer" href="https://mirrormediagroupla.com/#contact-us">Contact Us</a></li>
<li id="menu-item-41371" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41371"><a href="https://yovenice.com/best-of-venice-2021/">Best of Venice 2021</a></li>
</ul></div>      <!-- end -->
    </div>
  </div>
<!-- end -->

<!-- fly-over --><!-- end -->

<!-- hedader_layouts -->
  
    <header>
    
    <div class="header-ad"> 
    
<!-- /21621973880/yovenice_headerleaderboard -->
<div id='div-gpt-ad-1598567356379-0'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1598567356379-0'); });
  </script>
</div>
</div>
      
	</div>

      <div class="top pb-3 border-bottom brd-bold brd-black">
        <div class="w-logoline">
          <!-- logo -->
            <div class="logo f-meta l-black pt-3 px-3 p-lg-0" itemscope itemtype="https://schema.org/Organization">
                                <div itemscope itemtype="https://schema.org/ImageObject">
                  <a href="https://yovenice.com/" class="custom-logo-link" rel="home"><img width="400" height="400" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2019/08/cropped-yo-logo.png" class="custom-logo" alt="Yo! Venice!" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2019/08/cropped-yo-logo.png 400w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2019/08/cropped-yo-logo-150x150.png 150w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2019/08/cropped-yo-logo-300x300.png 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2019/08/cropped-yo-logo-350x350.png 350w" sizes="(max-width: 400px) 100vw, 400px" /></a>                </div>
                            <meta itemprop="name" content="Yo! Venice!">
            </div>
          <!-- end -->
          <div class="meta small f-text d-none d-lg-flex c-text">
            <span class="date">October 26, 2022</span>
            <span class="">#1 Local News, Forum, Information and Event Source for Venice Beach, California.</span>
          </div>
        </div>
      </div>

      <div class="bottom d-flex c-black l-black lh-1 f-meta border-bottom minus position-relative" id="w-menu">

            <div class="w-social d-none border-right px-3"><ul id="menu-social" class="menu"><li id="menu-item-35478" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35478"><a href="https://www.facebook.com/YoVenice/">facebook</a></li>
<li id="menu-item-35480" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35480"><a href="https://twitter.com/YoVenice">twitter</a></li>
</ul></div>
            <!-- menu -->
              <div class="w-menu d-none d-lg-flex c-meta ml-auto"><ul id="menu-main-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35481"><a href="/">Home</a></li>
<li class="weart-megamenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35750"><a href="https://yovenice.com/category/venice-beach-opinion/">Opinion</a><div class="weart-megamenu"><div class="w-100 bg-white shadow border-top"><div class="container"><div class="row"><div class="col-3 l-black py-4"><a href="https://yovenice.com/2022/10/25/column-money-messaging-that-is-persuasive-and-memorable-may-just-make-rick-caruso-our-next-mayor/"><div class="lazy bg-20" data-src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/caruso-bass.jpg"></div><span class="d-block mt-2 h6">Column: Money &#038; Messaging That Is Persuasive and Memorable May Just Make Rick Caruso Our Next Mayor!</span></a></div><div class="col-3 l-black py-4"><a href="https://yovenice.com/2022/10/25/column-the-flower-street-debacle-five-years-of-government-inaction-failure/"><div class="lazy bg-20" data-src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/feature-image-1.jpg"></div><span class="d-block mt-2 h6">Column: The Flower Street Debacle: Five Years of Government Inaction &#038; Failure!</span></a></div><div class="col-3 l-black py-4"><a href="https://yovenice.com/2022/10/22/column-excess-school-lands-for-teacher-housing/"><div class="lazy bg-20" data-src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Yovenice.jpg"></div><span class="d-block mt-2 h6">Column: Excess School Lands for Teacher Housing?</span></a></div><div class="col-3 l-black py-4"><a href="https://yovenice.com/2022/10/21/column-sparks-fly-at-south-brentwood-residents-association-council-forum/"><div class="lazy bg-20" data-src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/20221020_200115.jpg"></div><span class="d-block mt-2 h6">Column: Sparks Fly at South Brentwood Residents Association Council Forum</span></a></div></div></div></div></div></li>
<li class="weart-megamenu menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35749"><a href="https://yovenice.com/category/venice-beach-health/">Health</a><div class="weart-megamenu"><div class="w-100 bg-white shadow border-top"><div class="container"><div class="row"><div class="col-3 l-black py-4"><a href="https://yovenice.com/2022/10/17/100-miles-of-bus-only-lanes-within-five-years-on-city-council-plans/"><div class="lazy bg-20" data-src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-13-at-4.58.00-PM.png"></div><span class="d-block mt-2 h6">100 Miles of Bus-Only Lanes Within Five Years on City Council Plans</span></a></div></div></div></div></div></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44187"><a href="https://yovenice.com/2022-back-to-school-guide/">2022 Back to School Guide</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38070"><a target="_blank" rel="noopener noreferrer" href="https://mirrormediagroupla.com/">Advertising</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38071"><a target="_blank" rel="noopener noreferrer" href="https://mirrormediagroupla.com/">PR Services</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38072"><a target="_blank" rel="noopener noreferrer" href="https://mirrormediagroupla.com/#contact-us">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41371"><a href="https://yovenice.com/best-of-venice-2021/">Best of Venice 2021</a></li>
</ul></div>                              <div class="d-flex d-lg-none bars px-3 border-right mr-auto">
                  <a href="#menubutton">
                    <i class="fas fa-bars"></i>
                  </a>
                </div>
                          <!-- end -->

            <!-- search -->
              <div class="w-search px-3 border-left ml-auto">
                <a href="#w-search" class="search-indicator"><i class="fas fa-search"></i></a>
                <div class="search-box bg-2">
                  <form role="search" method="get" class="search-form d-block" action="https://yovenice.com/">
  <div class="input-group  input-group-sm">
    <input type="search" class="form-control search-field rounded-0 f-main border" placeholder="Search for..." aria-label="Search for..." name="s">
    <span class="input-group-btn">
      <button class="btn bg-1 c-white search-submit rounded-0" type="submit"><i class="fas fa-search"></i></button>
    </span>
  </div>
</form>
                </div>
              </div>
            <!-- end -->

      </div>

    </header>

  <!-- end -->

<main id="main" class="c-text f-text mb-5">
<div class="section">
<article itemscope itemtype="http://schema.org/NewsArticle" class="article-container">
      <meta itemscope itemprop="mainEntityOfPage" content="https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/" itemType="https://schema.org/WebPage" itemid="https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/"/>

    <!-- featured img -->
      <div class="wide">
        <div class="row">
          <div class="col-12">
                <!-- featured image -->
                <div class="featured-img" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
                        <meta itemprop="url" content="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-1100x733.jpg">
            <meta itemprop="width" content="1100">
            <meta itemprop="height" content="733">
            <img width="2560" height="1707" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-scaled.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-scaled.jpg 2560w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-300x200.jpg 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-1024x683.jpg 1024w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-768x512.jpg 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-1536x1024.jpg 1536w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-2048x1365.jpg 2048w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-730x487.jpg 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-350x233.jpg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-1100x733.jpg 1100w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-272x182.jpg 272w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-750x500.jpg 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-1140x760.jpg 1140w" sizes="(max-width: 2560px) 100vw, 2560px" /><div class="ccfic"><span class="ccfic-text">Left to right: Chuck Lorre, Gina Yashere, Liz Forer, Billy Gardell  Folake Olowofoyeku at Power of Us Event. Photo: David Crotty & Patrick McMullan via Getty Images.</span></div>          </div>
            <!-- end -->
            </div>
        </div>
      </div>
    <!-- end -->


    <!-- content-area -->
      <div class="container">

         <!-- header -->
                    <div class="row ">
            <div class="col-lg-10">
              <!-- article-header -->
                <header>
                  <h1 class="article-title h1 c-black my-4" itemprop="headline">Venice Family Clinic Honors Outgoing CEO Elizabeth Benson Forer at Power of Us Event</h1>
                </header>
              <!-- end -->
            </div>
          </div>
        <!-- end -->

        <div class="row justify-content-center">
          <div class="col-lg-8">
            <!-- excerpt -->
                          <!-- end -->
            

<!-- content -->
  <div class="article-content content l-1">
    <div class="clearfix">
<p><strong>October 23 Celebration featured Billy Gardell, Folake Olowofoyeku, Gina Yashere and more</strong></p>



<p>Venice Family Clinic, a nonprofit community health center providing comprehensive care to over 45,000 people in need from the Santa Monica Mountains through the South Bay, celebrated the collective impact of its community and paid tribute to CEO Elizabeth Benson Forer’s 28 years of visionary leadership at the Power of Us event on Sunday, Oct. 23.</p>



<p>The celebration included appearances by Billy Gardell, Folake Olowofoyeku and Gina Yashere, who star in “Bob Hearts Abishola.” Health care is a central theme for the series because Olowofoyeku&#8217;s character, Abishola, is a registered nurse who met Gardell’s character, Bob, after he suffered a heart attack. Yashere is also a co-creator, co-showrunner and executive producer on the series.</p>



<p>Prolific television producer Chuck Lorre also honored his long-time friend, Forer, during the event. For the past 20 years, Lorre has been a major donor to the Venice Family Clinic. Lorre has created and written numerous award-winning series, including “Bob Hearts Abishola,” “The Big Bang Theory,” “Mom,” “The Kominsky Method,” “Young Sheldon,” “Grace Under Fire,” “Two and Half Men” and many more.</p>



<p>The festivities included live music, immersive entertainment and a reception catered by Wolfgang Puck. The event honored Forer, who is retiring at the end of the year, and celebrated the Power of Us, Venice Family Clinic’s fundraising initiative that demonstrates the impact a united community can have on advancing health equity</p>



<p>“I am so proud of what we have been able to accomplish with the support of our generous donors, wonderful volunteers and dedicated staff. I am leaving this incredible organization secure in the knowledge that Venice Family Clinic is on a trajectory to accomplish even more,” said Forer. “The Power of Us speaks to our collective determination to find solutions to the challenges outlined in this powerful initiative: achieving health equity, building mental health access, controlling pandemics and epidemics, defeating homelessness, ending hunger and fighting for our children.”</p>



<p>The celebration offered guests the opportunity to support The Community Connection, a comprehensive model of care Venice Family Clinic launched earlier this year. The goal of The Community Connection is to deliver quality health care, mental health care and early childhood programming to children and families to ensure they have the tools to build healthy and successful lives. The Community Connection will expand across the Clinic’s sites, with a hub at the Clinic’s new building in Inglewood. The Clinic will honor donations to the “The Liz Forer Community Connection Fund” by naming “Liz’s Playground” at the Inglewood site.</p>



<p>The Power of Us event was presented by UCLA Health and championed by LA Care Health Plan. Other sponsors were California Community Foundation, Cedars Sinai, Health Net and Kaiser Permanente.</p>
</div>
    <div class="link-pages c-meta l-black f-meta clearfix">
          </div>
  </div>
<!-- end -->

<!-- share -->
    <!-- displayable meta -->
    <div class="d-block d-md-flex align-items-center justify-content-between mb-4 l-1 c-meta border-top py-3 mb-5">

      <div class="left small font-italic ">

        <div class="top d-flex">
                  <span class="author mr-1" itemprop="author" itemscope itemtype="https://schema.org/Person">
            By            <span itemprop="name"><a href="https://yovenice.com/author/yovenicestaff/" title="Posts by Yo Venice Staff" rel="author">Yo Venice Staff</a></span>
          </span>
        
                  <span class="date mr-1">
            <time itemprop="datePublished" datetime="2022-10-26">October 26, 2022</time>
            <meta itemprop="dateModified" content="2022-10-26"/>
          </span>
        
        </div>
        <div class="bottom">
          <span class="tags mr-1 d-inline-block">
                      </span>

          <span class="category mr-1  d-inline-block">
            in <a href="https://yovenice.com/category/news/" rel="category tag">News</a>, <a href="https://yovenice.com/category/upbeat-beat/" rel="category tag">Upbeat Beat</a>          </span>
        </div>
      </div>

      <div class="right mt-4 mt-md-0">
          <div class="weart-share lh-white">
    <!-- facebook -->
      <a class="bgh-black" href="https://www.facebook.com/sharer/sharer.php" onclick="var sharerFb = 'https://www.facebook.com/sharer/sharer.php?u=https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/'; window.open(sharerFb, 'sharerFb', 'width=626,height=436'); return false;"><i class="fab fa-facebook"></i></a>
    <!-- end -->

    <!-- Twitter -->
      <a class="bgh-black" href="https://twitter.com/share" onclick="var sharerTw = 'https://twitter.com/share?text=Venice Family Clinic Honors Outgoing CEO Elizabeth Benson Forer at Power of Us Event&amp;url=https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/'; window.open(sharerTw, 'sharerTw', 'width=550,height=520'); return false;"><i class="fab fa-twitter"></i></a>
    <!-- end -->

    <!-- Reddit -->
      <a class="bgh-black" href="https://www.reddit.com/submit" onclick="var sharerRd = 'https://www.reddit.com/submit?url=https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/&amp;title=Venice Family Clinic Honors Outgoing CEO Elizabeth Benson Forer at Power of Us Event'; window.open(sharerRd, 'sharerRd', 'width=840,height=464'); return false;"><i class="fab fa-reddit"></i></a>
    <!-- end -->

    <!-- Tumblr -->
      <a class="bgh-black" href="https://www.tumblr.com/share" onclick="var sharerTb = 'https://www.tumblr.com/share/link?url='; window.open(sharerTb + encodeURIComponent ( location.href ), 'sharerTb', 'width=450,height=430'); return false;"><i class="fab fa-tumblr"></i></a>
    <!-- end -->
  </div>
        </div>
    </div>
  <!-- end -->

  <!-- seo publisher -->
    <div class="d-none" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
      <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
                            <meta itemprop="url" content="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2019/08/cropped-yo-logo.png" >
              </div>
      <meta itemprop="name" content="Yo! Venice!">
    </div>
  <!-- end -->
  <!-- end -->

<!-- banner -->
      <div class="my-5 w-ads">
      <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script><script>  window.googletag = window.googletag || {cmd: []};  googletag.cmd.push(function() {    googletag.defineSlot('/21621973880/yovenice_articleinline', [728, 90], 'div-gpt-ad-1596069699224-0').addService(googletag.pubads());    googletag.pubads().enableSingleRequest();    googletag.enableServices();  });</script><!-- /21621973880/yovenice_articleinline --><div id='div-gpt-ad-1596069699224-0' style='width: 728px; height: 90px;'>  <script>    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1596069699224-0'); });  </script></div>    </div>
  <!-- end -->

<!-- related -->
          <div class="meta-title text-center f-title border-bottomm  pb-2 mb-3 border-bottom h6">
      <span class="c-1">Related Posts</span>
      <hr class="brd-black brd-bold my-1">
    </div>
      
    <div class="mb-4 related border-0 post-44735 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-upbeat-beat">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://yovenice.com/2022/10/26/cedars-sinai-supports-safety-net-organizations-in-cedars-sinai-marina-del-rey-hospital-area/" title="Cedars-Sinai Supports Safety Net Organizations in Cedars-Sinai Marina del Rey Hospital Area">
                              <img width="730" height="486" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-9-730x486.jpg" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-9-730x486.jpg 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-9-300x200.jpg 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-9-768x512.jpg 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-9-350x233.jpg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-9-272x182.jpg 272w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-9-750x500.jpg 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-9.jpg 800w" sizes="(max-width: 730px) 100vw, 730px" /><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://yovenice.com/category/news/" rel="category tag">News</a>, <a href="https://yovenice.com/category/upbeat-beat/" rel="category tag">Upbeat Beat</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://yovenice.com/2022/10/26/cedars-sinai-supports-safety-net-organizations-in-cedars-sinai-marina-del-rey-hospital-area/" title="Cedars-Sinai Supports Safety Net Organizations in Cedars-Sinai Marina del Rey Hospital Area">
                Cedars-Sinai Supports Safety Net Organizations in Cedars-Sinai Marina del Rey Hospital Area              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 26, 2022</span>      <span class="author"><a href="https://yovenice.com/author/yovenicestaff/" title="Posts by Yo Venice Staff" rel="author">Yo Venice Staff</a></span>
          </p>

    <div class="left d-none">
      <a href="https://yovenice.com/2022/10/26/cedars-sinai-supports-safety-net-organizations-in-cedars-sinai-marina-del-rey-hospital-area/" title="Cedars-Sinai Supports Safety Net Organizations in Cedars-Sinai Marina del Rey Hospital Area">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 26, 2022</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">$4 million in grants awarded to dozens of organizations in the communities surrounding Cedars-Sinai Marina del Rey Hospital  Cedars-Sinai awarded...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 related border-top post-44732 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-upbeat-beat">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://yovenice.com/2022/10/26/girl-scouts-of-greater-los-angeles-receives-record-breaking-donation-from-mackenzie-scott/" title="Girl Scouts of Greater Los Angeles Receives Record-Breaking Donation From Mackenzie Scott">
                              <img width="730" height="486" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-730x486.jpg" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-730x486.jpg 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-300x200.jpg 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-1024x682.jpg 1024w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-768x511.jpg 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-1536x1023.jpg 1536w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-2048x1363.jpg 2048w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-350x233.jpg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-1100x732.jpg 1100w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-272x182.jpg 272w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-750x499.jpg 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-1140x759.jpg 1140w" sizes="(max-width: 730px) 100vw, 730px" /><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://yovenice.com/category/news/" rel="category tag">News</a>, <a href="https://yovenice.com/category/upbeat-beat/" rel="category tag">Upbeat Beat</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://yovenice.com/2022/10/26/girl-scouts-of-greater-los-angeles-receives-record-breaking-donation-from-mackenzie-scott/" title="Girl Scouts of Greater Los Angeles Receives Record-Breaking Donation From Mackenzie Scott">
                Girl Scouts of Greater Los Angeles Receives Record-Breaking Donation From Mackenzie Scott              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 26, 2022</span>      <span class="author"><a href="https://yovenice.com/author/yovenicestaff/" title="Posts by Yo Venice Staff" rel="author">Yo Venice Staff</a></span>
          </p>

    <div class="left d-none">
      <a href="https://yovenice.com/2022/10/26/girl-scouts-of-greater-los-angeles-receives-record-breaking-donation-from-mackenzie-scott/" title="Girl Scouts of Greater Los Angeles Receives Record-Breaking Donation From Mackenzie Scott">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 26, 2022</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Transformational gift will allow non-profit to provide girls throughout Greater Los Angeles a pathway to become empowered and compassionate leaders...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 related border-top post-44729 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-upbeat-beat">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://yovenice.com/2022/10/26/96-year-old-del-rey-resident-writes-note-to-lafd-thanking-firefighters-for-assistance-after-fall/" title="96-Year-Old Del Rey Resident Writes Note to LAFD Thanking Firefighters for Assistance After Fall">
                              <img width="730" height="457" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-2.21.06-PM-730x457.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-2.21.06-PM-730x457.png 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-2.21.06-PM-300x188.png 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-2.21.06-PM-1024x642.png 1024w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-2.21.06-PM-768x481.png 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-2.21.06-PM-350x219.png 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-2.21.06-PM-1100x689.png 1100w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-2.21.06-PM-750x470.png 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-2.21.06-PM-1140x714.png 1140w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-2.21.06-PM.png 1200w" sizes="(max-width: 730px) 100vw, 730px" /><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://yovenice.com/category/news/" rel="category tag">News</a>, <a href="https://yovenice.com/category/upbeat-beat/" rel="category tag">Upbeat Beat</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://yovenice.com/2022/10/26/96-year-old-del-rey-resident-writes-note-to-lafd-thanking-firefighters-for-assistance-after-fall/" title="96-Year-Old Del Rey Resident Writes Note to LAFD Thanking Firefighters for Assistance After Fall">
                96-Year-Old Del Rey Resident Writes Note to LAFD Thanking Firefighters for Assistance After Fall              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 26, 2022</span>      <span class="author"><a href="https://yovenice.com/author/yovenicestaff/" title="Posts by Yo Venice Staff" rel="author">Yo Venice Staff</a></span>
          </p>

    <div class="left d-none">
      <a href="https://yovenice.com/2022/10/26/96-year-old-del-rey-resident-writes-note-to-lafd-thanking-firefighters-for-assistance-after-fall/" title="96-Year-Old Del Rey Resident Writes Note to LAFD Thanking Firefighters for Assistance After Fall">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 26, 2022</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">By LAFD Spokesperson Amy Bastman On April 6, 2022, Eileen Porch experienced an incident that would cause her to call...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 related border-top post-44713 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-video">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://yovenice.com/2022/10/25/tour-the-ballona-creek-trash-interceptor-now-fully-operational/" title="Tour the Ballona Creek Trash Interceptor Now Fully Operational">
                              <img width="730" height="464" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-730x464.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-730x464.png 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-300x191.png 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-1024x651.png 1024w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-768x488.png 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-1536x976.png 1536w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-2048x1302.png 2048w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-350x222.png 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-1100x699.png 1100w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-750x477.png 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-1140x725.png 1140w" sizes="(max-width: 730px) 100vw, 730px" /><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://yovenice.com/category/news/" rel="category tag">News</a>, <a href="https://yovenice.com/category/video/" rel="category tag">Video</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://yovenice.com/2022/10/25/tour-the-ballona-creek-trash-interceptor-now-fully-operational/" title="Tour the Ballona Creek Trash Interceptor Now Fully Operational">
                Tour the Ballona Creek Trash Interceptor Now Fully Operational              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 25, 2022</span>      <span class="author"><a href="https://yovenice.com/author/juliet-lemar/" title="Posts by Juliet Lemar" rel="author">Juliet Lemar</a></span>
          </p>

    <div class="left d-none">
      <a href="https://yovenice.com/2022/10/25/tour-the-ballona-creek-trash-interceptor-now-fully-operational/" title="Tour the Ballona Creek Trash Interceptor Now Fully Operational">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 25, 2022</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">The Ballona Creek Trash Interceptor™ Pilot Project has officially launched. In this video we take a tour onboard and meet...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 related border-top post-44710 post type-post status-publish format-standard has-post-thumbnail hentry category-education category-news category-video">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://yovenice.com/2022/10/25/local-school-closed-after-water-and-mold-damage-parents-claim-neglect/" title="Local School Closed After Water and Mold Damage Parents Claim Neglect">
                              <img width="730" height="446" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-730x446.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-730x446.png 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-300x183.png 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-1024x626.png 1024w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-768x469.png 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-1536x939.png 1536w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-2048x1252.png 2048w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-350x214.png 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-1100x672.png 1100w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-750x458.png 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-1140x697.png 1140w" sizes="(max-width: 730px) 100vw, 730px" /><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://yovenice.com/category/news/education/" rel="category tag">Education</a>, <a href="https://yovenice.com/category/news/" rel="category tag">News</a>, <a href="https://yovenice.com/category/video/" rel="category tag">Video</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://yovenice.com/2022/10/25/local-school-closed-after-water-and-mold-damage-parents-claim-neglect/" title="Local School Closed After Water and Mold Damage Parents Claim Neglect">
                Local School Closed After Water and Mold Damage Parents Claim Neglect              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 25, 2022</span>      <span class="author"><a href="https://yovenice.com/author/juliet-lemar/" title="Posts by Juliet Lemar" rel="author">Juliet Lemar</a></span>
          </p>

    <div class="left d-none">
      <a href="https://yovenice.com/2022/10/25/local-school-closed-after-water-and-mold-damage-parents-claim-neglect/" title="Local School Closed After Water and Mold Damage Parents Claim Neglect">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 25, 2022</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Parents of children attending John Muir Elementary say the district failed to respond to water damage and mold leading to...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 related border-top post-44692 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-venice-beach-real-estate category-video">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://yovenice.com/2022/10/24/new-39-unit-affordable-senior-housing-unveiled-in-santa-monica/" title="New 39 Unit Affordable Senior Housing Unveiled in Santa Monica">
                              <img width="730" height="487" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-730x487.jpg" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-730x487.jpg 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-300x200.jpg 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-1024x684.jpg 1024w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-768x513.jpg 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-1536x1025.jpg 1536w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-2048x1367.jpg 2048w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-350x234.jpg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-1100x734.jpg 1100w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-272x182.jpg 272w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-750x501.jpg 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-1140x761.jpg 1140w" sizes="(max-width: 730px) 100vw, 730px" /><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://yovenice.com/category/news/" rel="category tag">News</a>, <a href="https://yovenice.com/category/venice-beach-real-estate/" rel="category tag">Real Estate</a>, <a href="https://yovenice.com/category/video/" rel="category tag">Video</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://yovenice.com/2022/10/24/new-39-unit-affordable-senior-housing-unveiled-in-santa-monica/" title="New 39 Unit Affordable Senior Housing Unveiled in Santa Monica">
                New 39 Unit Affordable Senior Housing Unveiled in Santa Monica              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 24, 2022</span>      <span class="author"><a href="https://yovenice.com/author/juliet-lemar/" title="Posts by Juliet Lemar" rel="author">Juliet Lemar</a></span>
          </p>

    <div class="left d-none">
      <a href="https://yovenice.com/2022/10/24/new-39-unit-affordable-senior-housing-unveiled-in-santa-monica/" title="New 39 Unit Affordable Senior Housing Unveiled in Santa Monica">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 24, 2022</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Magnolia Villas is a newly constructed 39 unit 62+ affordable housing community on Broadway and 10th. Learn what services it...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 related border-top post-44701 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-venice-beach-real-estate">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://yovenice.com/2022/10/22/officials-green-light-mar-vista-infill-development/" title="Officials Green Light Mar Vista Infill Development">
                              <img width="730" height="441" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-and-Westside-Infill-730x441.jpg" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-and-Westside-Infill-730x441.jpg 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-and-Westside-Infill-300x181.jpg 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-and-Westside-Infill-1024x618.jpg 1024w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-and-Westside-Infill-768x464.jpg 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-and-Westside-Infill-1536x927.jpg 1536w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-and-Westside-Infill-350x211.jpg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-and-Westside-Infill-1100x664.jpg 1100w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-and-Westside-Infill-750x453.jpg 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-and-Westside-Infill-1140x688.jpg 1140w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-and-Westside-Infill.jpg 1920w" sizes="(max-width: 730px) 100vw, 730px" /><div class="ccfic"><span class="ccfic-text">Rendering: Breakform Design.</span></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://yovenice.com/category/news/" rel="category tag">News</a>, <a href="https://yovenice.com/category/venice-beach-real-estate/" rel="category tag">Real Estate</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://yovenice.com/2022/10/22/officials-green-light-mar-vista-infill-development/" title="Officials Green Light Mar Vista Infill Development">
                Officials Green Light Mar Vista Infill Development              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 22, 2022</span>      <span class="author"><a href="https://yovenice.com/author/yovenicestaff/" title="Posts by Yo Venice Staff" rel="author">Yo Venice Staff</a></span>
          </p>

    <div class="left d-none">
      <a href="https://yovenice.com/2022/10/22/officials-green-light-mar-vista-infill-development/" title="Officials Green Light Mar Vista Infill Development">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 22, 2022</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Los Angeles City Planning Commission approves infill developments in Westwood and Mar Vista By Dolores Quintana The Los Angeles City...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 related border-top post-44698 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-venice-beach-real-estate">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://yovenice.com/2022/10/22/34-unit-development-proposed-for-site-of-mar-vista-liquor-store-and-laundromat/" title="34-Unit Development Proposed for Site of Mar Vista Liquor Store and Laundromat">
                              <img width="730" height="511" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-mar-vista-730x511.jpg" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-mar-vista-730x511.jpg 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-mar-vista-300x210.jpg 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-mar-vista-1024x717.jpg 1024w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-mar-vista-768x538.jpg 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-mar-vista-1536x1076.jpg 1536w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-mar-vista-350x245.jpg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-mar-vista-1100x771.jpg 1100w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-mar-vista-750x525.jpg 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-mar-vista-1140x799.jpg 1140w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-mar-vista.jpg 1713w" sizes="(max-width: 730px) 100vw, 730px" /><div class="ccfic"><span class="ccfic-text">Rendering: GA Engineering.</span></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://yovenice.com/category/news/" rel="category tag">News</a>, <a href="https://yovenice.com/category/venice-beach-real-estate/" rel="category tag">Real Estate</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://yovenice.com/2022/10/22/34-unit-development-proposed-for-site-of-mar-vista-liquor-store-and-laundromat/" title="34-Unit Development Proposed for Site of Mar Vista Liquor Store and Laundromat">
                34-Unit Development Proposed for Site of Mar Vista Liquor Store and Laundromat              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 22, 2022</span>      <span class="author"><a href="https://yovenice.com/author/yovenicestaff/" title="Posts by Yo Venice Staff" rel="author">Yo Venice Staff</a></span>
          </p>

    <div class="left d-none">
      <a href="https://yovenice.com/2022/10/22/34-unit-development-proposed-for-site-of-mar-vista-liquor-store-and-laundromat/" title="34-Unit Development Proposed for Site of Mar Vista Liquor Store and Laundromat">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 22, 2022</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Mixed-use development planned for 12701 Washington Place By Dolores Quintana Mar Vista will be the site of a new mixed-use...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 related border-top post-44695 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-venice-beach-real-estate">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://yovenice.com/2022/10/22/venices-thatcher-yard-construction-goes-vertical/" title="Venice’s Thatcher Yard Construction Goes Vertical">
                              <img width="730" height="500" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/thatcher-yard-1-730x500.jpg" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/thatcher-yard-1-730x500.jpg 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/thatcher-yard-1-300x205.jpg 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/thatcher-yard-1-768x526.jpg 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/thatcher-yard-1-350x240.jpg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/thatcher-yard-1-750x513.jpg 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/thatcher-yard-1.jpg 900w" sizes="(max-width: 730px) 100vw, 730px" /><div class="ccfic"><span class="ccfic-text">Rendering: Official. </span></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://yovenice.com/category/news/" rel="category tag">News</a>, <a href="https://yovenice.com/category/venice-beach-real-estate/" rel="category tag">Real Estate</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://yovenice.com/2022/10/22/venices-thatcher-yard-construction-goes-vertical/" title="Venice’s Thatcher Yard Construction Goes Vertical">
                Venice’s Thatcher Yard Construction Goes Vertical              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 22, 2022</span>      <span class="author"><a href="https://yovenice.com/author/yovenicestaff/" title="Posts by Yo Venice Staff" rel="author">Yo Venice Staff</a></span>
          </p>

    <div class="left d-none">
      <a href="https://yovenice.com/2022/10/22/venices-thatcher-yard-construction-goes-vertical/" title="Venice’s Thatcher Yard Construction Goes Vertical">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 22, 2022</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Development will bring 98 units of affordable housing to Venice By Dolores Quintana Thomas Safran &amp; Associates have a new...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 related border-top post-44704 post type-post status-publish format-standard has-post-thumbnail hentry category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://yovenice.com/2022/10/21/councilmembers-de-leo-and-cedillo-still-not-resigning-despite-mounting-pressure/" title="Councilmembers de Leo and Cedillo Still Not Resigning Despite Mounting Pressure">
                              <img width="730" height="487" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-de-leon-730x487.jpg" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-de-leon-730x487.jpg 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-de-leon-300x200.jpg 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-de-leon-768x512.jpg 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-de-leon-350x233.jpg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-de-leon-272x182.jpg 272w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-de-leon-750x500.jpg 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-de-leon.jpg 1024w" sizes="(max-width: 730px) 100vw, 730px" /><div class="ccfic"><span class="ccfic-text">Kevin de Leon. Photo: Official.</span></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://yovenice.com/category/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://yovenice.com/2022/10/21/councilmembers-de-leo-and-cedillo-still-not-resigning-despite-mounting-pressure/" title="Councilmembers de Leo and Cedillo Still Not Resigning Despite Mounting Pressure">
                Councilmembers de Leo and Cedillo Still Not Resigning Despite Mounting Pressure              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 21, 2022</span>      <span class="author"><a href="https://yovenice.com/author/yovenicestaff/" title="Posts by Yo Venice Staff" rel="author">Yo Venice Staff</a></span>
          </p>

    <div class="left d-none">
      <a href="https://yovenice.com/2022/10/21/councilmembers-de-leo-and-cedillo-still-not-resigning-despite-mounting-pressure/" title="Councilmembers de Leo and Cedillo Still Not Resigning Despite Mounting Pressure">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 21, 2022</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">In an interview, de Leon cites needs of “underrepresented” district  By Dolors Quintana  Until Wednesday, City Councilmember Kevin de Leon...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 related border-top post-44669 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-veterans category-video">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://yovenice.com/2022/10/21/100-disabled-veterans-not-eligible-for-new-v-a-housing/" title="100% Disabled Veterans Not Eligible for New V.A Housing">
                              <img width="730" height="458" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-palisades-730x458.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-palisades-730x458.png 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-palisades-300x188.png 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-palisades-1024x642.png 1024w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-palisades-768x481.png 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-palisades-1536x963.png 1536w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-palisades-2048x1284.png 2048w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-palisades-350x219.png 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-palisades-1100x689.png 1100w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-palisades-750x470.png 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-palisades-1140x715.png 1140w" sizes="(max-width: 730px) 100vw, 730px" /><div class="ccfic"></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://yovenice.com/category/news/" rel="category tag">News</a>, <a href="https://yovenice.com/category/veterans/" rel="category tag">Veterans</a>, <a href="https://yovenice.com/category/video/" rel="category tag">Video</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://yovenice.com/2022/10/21/100-disabled-veterans-not-eligible-for-new-v-a-housing/" title="100% Disabled Veterans Not Eligible for New V.A Housing">
                100% Disabled Veterans Not Eligible for New V.A Housing              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 21, 2022</span>      <span class="author"><a href="https://yovenice.com/author/juliet-lemar/" title="Posts by Juliet Lemar" rel="author">Juliet Lemar</a></span>
          </p>

    <div class="left d-none">
      <a href="https://yovenice.com/2022/10/21/100-disabled-veterans-not-eligible-for-new-v-a-housing/" title="100% Disabled Veterans Not Eligible for New V.A Housing">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 21, 2022</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Veterans receiving over 30%-60% AMI will be ineligible for housing on the West L.A VA Campus.&nbsp;.Video sponsored by The Canyon...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 related border-top post-44675 post type-post status-publish format-standard has-post-thumbnail hentry category-crime category-news category-transportation">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://yovenice.com/2022/10/21/driver-leads-police-on-chase-from-san-diego-to-lax/" title="Driver Leads Police on Chase From San Diego to LAX">
                              <img width="730" height="489" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-20-at-3.39.23-PM-730x489.png" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-20-at-3.39.23-PM-730x489.png 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-20-at-3.39.23-PM-300x201.png 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-20-at-3.39.23-PM-768x515.png 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-20-at-3.39.23-PM-350x235.png 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-20-at-3.39.23-PM-272x182.png 272w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-20-at-3.39.23-PM-750x503.png 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-20-at-3.39.23-PM.png 900w" sizes="(max-width: 730px) 100vw, 730px" /><div class="ccfic"><span class="ccfic-text">Photo: Citizen App</span></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://yovenice.com/category/news/crime/" rel="category tag">Crime</a>, <a href="https://yovenice.com/category/news/" rel="category tag">News</a>, <a href="https://yovenice.com/category/news/transportation/" rel="category tag">Transportation</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://yovenice.com/2022/10/21/driver-leads-police-on-chase-from-san-diego-to-lax/" title="Driver Leads Police on Chase From San Diego to LAX">
                Driver Leads Police on Chase From San Diego to LAX              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 21, 2022</span>      <span class="author"><a href="https://yovenice.com/author/yovenicestaff/" title="Posts by Yo Venice Staff" rel="author">Yo Venice Staff</a></span>
          </p>

    <div class="left d-none">
      <a href="https://yovenice.com/2022/10/21/driver-leads-police-on-chase-from-san-diego-to-lax/" title="Driver Leads Police on Chase From San Diego to LAX">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 21, 2022</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Thursday afternoon pursuit ends in a standoff at airport A driver led police on a chase Thursday that started in...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 related border-top post-44668 post type-post status-publish format-standard has-post-thumbnail hentry category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://yovenice.com/2022/10/20/socal-workers-unions-oppose-proposed-kroger-albertsons-merger/" title="SoCal Workers’ Unions Oppose Proposed Kroger-Albertsons Merger">
                              <img width="730" height="486" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-brentwood-photo-730x486.jpeg" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-brentwood-photo-730x486.jpeg 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-brentwood-photo-300x200.jpeg 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-brentwood-photo-1024x682.jpeg 1024w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-brentwood-photo-768x512.jpeg 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-brentwood-photo-1536x1024.jpeg 1536w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-brentwood-photo-2048x1365.jpeg 2048w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-brentwood-photo-350x233.jpeg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-brentwood-photo-1100x733.jpeg 1100w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-brentwood-photo-272x182.jpeg 272w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-brentwood-photo-750x500.jpeg 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-brentwood-photo-1140x760.jpeg 1140w" sizes="(max-width: 730px) 100vw, 730px" /><div class="ccfic"><span class="ccfic-text">Photo: Sam Catanzaro</span></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://yovenice.com/category/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://yovenice.com/2022/10/20/socal-workers-unions-oppose-proposed-kroger-albertsons-merger/" title="SoCal Workers’ Unions Oppose Proposed Kroger-Albertsons Merger">
                SoCal Workers’ Unions Oppose Proposed Kroger-Albertsons Merger              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 20, 2022</span>      <span class="author"><a href="https://yovenice.com/author/yovenicestaff/" title="Posts by Yo Venice Staff" rel="author">Yo Venice Staff</a></span>
          </p>

    <div class="left d-none">
      <a href="https://yovenice.com/2022/10/20/socal-workers-unions-oppose-proposed-kroger-albertsons-merger/" title="SoCal Workers’ Unions Oppose Proposed Kroger-Albertsons Merger">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 20, 2022</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Kroger looking to purchase Albertsons for $20 billion By Dolores Quintana UFCW Locals 7, 324, 367, 770&nbsp; and 3000, union...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 related border-top post-44662 post type-post status-publish format-standard has-post-thumbnail hentry category-dining category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://yovenice.com/2022/10/19/trader-joes-free-samples-are-back/" title="Trader Joe’s Free Samples Are Back">
                              <img width="730" height="487" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/IMG_6027-730x487.jpg" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/IMG_6027-730x487.jpg 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/IMG_6027-300x200.jpg 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/IMG_6027-1024x683.jpg 1024w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/IMG_6027-768x512.jpg 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/IMG_6027-1536x1024.jpg 1536w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/IMG_6027-2048x1365.jpg 2048w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/IMG_6027-350x233.jpg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/IMG_6027-1100x733.jpg 1100w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/IMG_6027-272x182.jpg 272w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/IMG_6027-750x500.jpg 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/IMG_6027-1140x760.jpg 1140w" sizes="(max-width: 730px) 100vw, 730px" /><div class="ccfic"><span class="ccfic-text">Photo: Sam Catanzaro.</span></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://yovenice.com/category/dining/" rel="category tag">Dining</a>, <a href="https://yovenice.com/category/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://yovenice.com/2022/10/19/trader-joes-free-samples-are-back/" title="Trader Joe’s Free Samples Are Back">
                Trader Joe’s Free Samples Are Back              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 19, 2022</span>      <span class="author"><a href="https://yovenice.com/author/yovenicestaff/" title="Posts by Yo Venice Staff" rel="author">Yo Venice Staff</a></span>
          </p>

    <div class="left d-none">
      <a href="https://yovenice.com/2022/10/19/trader-joes-free-samples-are-back/" title="Trader Joe’s Free Samples Are Back">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 19, 2022</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Free coffee will not be returning By Dolores Quintana If you have been missing the always popular free samples at...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>


    <div class="mb-4 related border-top post-44659 post type-post status-publish format-standard has-post-thumbnail hentry category-dining category-news">
          <div class="row no-gutters list-item">

      <!-- img -->
                  <div class="col-md-6 pr-md-4 featured-img l-black ">
            <a href="https://yovenice.com/2022/10/19/dinahs-family-restaurant-refusing-to-leave-historic-building-during-construction/" title="Dinah’s Family Restaurant Refusing to Leave Historic Building During Construction">
                              <img width="730" height="485" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/200692835_342940214103435_1852583769916753931_n-730x485.jpg" class="attachment-weart-grid size-weart-grid wp-post-image" alt="" srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/200692835_342940214103435_1852583769916753931_n-730x485.jpg 730w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/200692835_342940214103435_1852583769916753931_n-300x199.jpg 300w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/200692835_342940214103435_1852583769916753931_n-768x510.jpg 768w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/200692835_342940214103435_1852583769916753931_n-350x233.jpg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/200692835_342940214103435_1852583769916753931_n-272x182.jpg 272w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/200692835_342940214103435_1852583769916753931_n-750x498.jpg 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/200692835_342940214103435_1852583769916753931_n.jpg 900w" sizes="(max-width: 730px) 100vw, 730px" /><div class="ccfic"><span class="ccfic-text">Photo: Facebook (@DinahsFamilyRestaurant).</span></div>                          </a>
          </div>
              <!-- end -->

      <!-- text -->
        <div class="col ">
          <!-- head -->
            <!-- cat -->
                              <div class="weart-cat-badge mt-4 mb-3 d-none d-md-flex">
                  <div class="bg-1 l-white c-white f-meta">
                    <a href="https://yovenice.com/category/dining/" rel="category tag">Dining</a>, <a href="https://yovenice.com/category/news/" rel="category tag">News</a>                  </div>
                </div>
                          <!-- end -->
            <h2 class="title l-black lh-1 mb-3 mt-4 mt-md-0 h5">
              <a href="https://yovenice.com/2022/10/19/dinahs-family-restaurant-refusing-to-leave-historic-building-during-construction/" title="Dinah’s Family Restaurant Refusing to Leave Historic Building During Construction">
                Dinah’s Family Restaurant Refusing to Leave Historic Building During Construction              </a>
            </h2>
              <div class="c-meta l-meta">
    <p class="small font-italic">
      <span class="date">October 19, 2022</span>      <span class="author"><a href="https://yovenice.com/author/yovenicestaff/" title="Posts by Yo Venice Staff" rel="author">Yo Venice Staff</a></span>
          </p>

    <div class="left d-none">
      <a href="https://yovenice.com/2022/10/19/dinahs-family-restaurant-refusing-to-leave-historic-building-during-construction/" title="Dinah’s Family Restaurant Refusing to Leave Historic Building During Construction">
        Read more<i class="fas fa-angle-right ml-1"></i>
      </a>
    </div>
    <div class="right d-none">
      <span class="date">October 19, 2022</span>      <span class="comment_num f-meta"><i class="far fa-comment mr-1"></i></span>
    </div>

  </div>
            <!-- end -->
          <!-- exc -->
                          <div class="excerpt c-meta mb-3">
                <p class="m-0">Redevelopment leaves future of restaurant uncertain By Dolores Quintana  Dinah’s Family Restaurant has refused to leave their restaurant while the...</p>
              </div>
                      <!-- end -->
        </div>
      <!-- end -->

    </div>
      </div>

  <!-- end -->

<!-- comment -->
  <div id="weart-comments" class="my-5">
    
<!-- comment form -->
  <!-- end -->
  </div>
<!-- end -->          </div>
          <!-- sidebar -->
              <div class="sidebar col-lg-4 c-text l-text border-left">
    <div class="sidebar-inner " id="sidebar-inner">
      <div id="search-2" class="widget_search box mb-5"><form role="search" method="get" class="search-form d-block" action="https://yovenice.com/">
  <div class="input-group  input-group-sm">
    <input type="search" class="form-control search-field rounded-0 f-main border" placeholder="Search for..." aria-label="Search for..." name="s">
    <span class="input-group-btn">
      <button class="btn bg-1 c-white search-submit rounded-0" type="submit"><i class="fas fa-search"></i></button>
    </span>
  </div>
</form>
</div><div id="custom_html-2" class="widget_text widget_custom_html box mb-5"><div class="textwidget custom-html-widget"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/21621973880/yovenice_sidebarhalfpage', [300, 600]).display();
</script></div></div><div id="custom_html-8" class="widget_text widget_custom_html box mb-5"><h3 class="sidebar-title f-meta c-1"><span class="title">Newsletter</span></h3><div class="textwidget custom-html-widget"><p class="sub">Subscribe to our newsletter to receive the latest news and events in Venice and the surrounding areas! test</p>
</div></div><div id="mc4wp_form_widget-2" class="widget_mc4wp_form_widget box mb-5"><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.8.3 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-36302" method="post" data-id="36302" data-name="newsletter" ><div class="mc4wp-form-fields"><p>
		<input type="email" name="EMAIL" placeholder="Your email address" required />
</p>

<p>
    <label>If you'd like to subscribe to additional lists, please select any here!</label>
    <label>
        <input name="_mc4wp_lists[]" type="checkbox" value="33f79e7e4d"> <span>The Pride LA</span>
    </label>
    <label>
        <input name="_mc4wp_lists[]" type="checkbox" value="382281a661"> <span>Brentwood News</span>
    </label>
    <label>
        <input name="_mc4wp_lists[]" type="checkbox" value="5fac618226"> <span>Century City-Westwood News</span>
    </label>
    <label>
        <input name="_mc4wp_lists[]" type="checkbox" value="a3d1b6d535"> <span>Westside Today</span>
    </label>
    <label>
        <input name="_mc4wp_lists[]" type="checkbox" value="d0b5733862"> <span>Santa Monica Mirror</span>
    </label>
    <label>
        <input name="_mc4wp_lists[]" type="checkbox" value="ec7d882848"> <span>Palisades News</span>
    </label>
</p>

<p>
	<input type="submit" value="Sign up" />
</p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1666784812" /><input type="hidden" name="_mc4wp_form_id" value="36302" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin --></div><div id="custom_html-3" class="widget_text widget_custom_html box mb-5"><div class="textwidget custom-html-widget"><script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/21621973880/yovenice_sidebar_tower_2', [300, 600], 'div-gpt-ad-1596069556633-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<!-- /21621973880/yovenice_sidebar_tower_2 -->
<div id='div-gpt-ad-1596069556633-0' style='width: 300px; height: 600px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1596069556633-0'); });
  </script>
</div></div></div><div id="custom_html-4" class="widget_text widget_custom_html box mb-5"><h3 class="sidebar-title f-meta c-1"><span class="title">DIGITAL</span></h3><div class="textwidget custom-html-widget"><div style="position:relative;padding-top:max(60%,326px);height:0;width:100%"><iframe allow="clipboard-write" sandbox="allow-top-navigation allow-top-navigation-by-user-activation allow-downloads allow-scripts allow-same-origin allow-popups allow-modals allow-popups-to-escape-sandbox" allowfullscreen="true" style="position:absolute;border:none;width:100%;height:100%;left:0;right:0;top:0;bottom:0;" src="https://e.issuu.com/embed.html?d=yo_venice_09-29-22lowres&u=santamonicamirror"></iframe></div></div></div><div id="custom_html-6" class="widget_text widget_custom_html box mb-5"><h3 class="sidebar-title f-meta c-1"><span class="title">RECENT POSTS</span></h3><div class="textwidget custom-html-widget"></div></div><div id="epic_module_block_1-2" class="widget_epic_module_block_1 box mb-5"><div  class="jeg_postblock_1 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 epic_module_44736_0_63591e2c84098  normal " data-unique="epic_module_44736_0_63591e2c84098">
                
                <div class="jeg_block_container jeg_load_more_flag">
                
                <div class="jeg_posts">
                <article class="jeg_post jeg_pl_lg_1 post-44736 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-upbeat-beat">
                    <div class="jeg_thumb">
                
                <a href="https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/"><div class="thumbnail-container animate-lazy  size-500 "><img width="360" height="180" src="https://yovenice.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-360x180 size-epic-360x180 lazyload wp-post-image" alt="Venice Family Clinic Honors Outgoing CEO Elizabeth Benson Forer at Power of Us Event" data-src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-360x180.jpg" data-sizes="auto" data-srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-360x180.jpg 360w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-750x375.jpg 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Venice-Photo-1140x570.jpg 1140w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">Left to right: Chuck Lorre, Gina Yashere, Liz Forer, Billy Gardell  Folake Olowofoyeku at Power of Us Event. Photo: David Crotty & Patrick McMullan via Getty Images.</span></div></div></a>
                <div class="jeg_post_category">
                    <span><a href="https://yovenice.com/category/news/" class="category-news">News</a></span>
                </div>
            </div>
            <div class="jeg_postblock_content">
                <h3 property="headline" class="jeg_post_title">
                    <a href="https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/">Venice Family Clinic Honors Outgoing CEO Elizabeth Benson Forer at Power of Us Event</a>
                </h3>
                <div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://yovenice.com/author/yovenicestaff/">Yo Venice Staff</a></div><div class="jeg_meta_date"><a href="https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/"><i class="fa fa-clock-o"></i> October 26, 2022</a></div><div class="jeg_meta_comment"><a href="https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/#respond" ><i class="fa fa-comment-o"></i> 0</a></div></div>
                <div class="jeg_post_excerpt">
                    <p>October 23 Celebration featured Billy Gardell, Folake Olowofoyeku, Gina Yashere and more Venice Family Clinic, a nonprofit community health center...</p>
                    <a href="https://yovenice.com/2022/10/26/venice-family-clinic-honors-outgoing-ceo-elizabeth-benson-forer-at-power-of-us-event/" class="jeg_readmore">Read more</a>
                </div>
            </div>
                </article>
                <div class="jeg_postsmall">
                    <article class="jeg_post jeg_pl_sm post-44735 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-upbeat-beat">
                <div class="jeg_thumb">
                    
                    <a href="https://yovenice.com/2022/10/26/cedars-sinai-supports-safety-net-organizations-in-cedars-sinai-marina-del-rey-hospital-area/">
                        <div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://yovenice.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="Cedars-Sinai Supports Safety Net Organizations in Cedars-Sinai Marina del Rey Hospital Area" data-src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-9-120x86.jpg" data-sizes="auto" data-srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-9-120x86.jpg 120w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-9-350x250.jpg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-9-750x533.jpg 750w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">Left to right: Chuck Lorre, Gina Yashere, Liz Forer, Billy Gardell  Folake Olowofoyeku at Power of Us Event. Photo: David Crotty & Patrick McMullan via Getty Images.</span></div></div>
                    </a>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://yovenice.com/2022/10/26/cedars-sinai-supports-safety-net-organizations-in-cedars-sinai-marina-del-rey-hospital-area/">Cedars-Sinai Supports Safety Net Organizations in Cedars-Sinai Marina del Rey Hospital Area</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://yovenice.com/2022/10/26/cedars-sinai-supports-safety-net-organizations-in-cedars-sinai-marina-del-rey-hospital-area/" ><i class="fa fa-clock-o"></i> October 26, 2022</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_sm post-44732 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-upbeat-beat">
                <div class="jeg_thumb">
                    
                    <a href="https://yovenice.com/2022/10/26/girl-scouts-of-greater-los-angeles-receives-record-breaking-donation-from-mackenzie-scott/">
                        <div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://yovenice.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="Girl Scouts of Greater Los Angeles Receives Record-Breaking Donation From Mackenzie Scott" data-src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-120x86.jpg" data-sizes="auto" data-srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-120x86.jpg 120w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-350x250.jpg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-750x536.jpg 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/unnamed-7-1140x815.jpg 1140w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">Left to right: Chuck Lorre, Gina Yashere, Liz Forer, Billy Gardell  Folake Olowofoyeku at Power of Us Event. Photo: David Crotty & Patrick McMullan via Getty Images.</span></div></div>
                    </a>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://yovenice.com/2022/10/26/girl-scouts-of-greater-los-angeles-receives-record-breaking-donation-from-mackenzie-scott/">Girl Scouts of Greater Los Angeles Receives Record-Breaking Donation From Mackenzie Scott</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://yovenice.com/2022/10/26/girl-scouts-of-greater-los-angeles-receives-record-breaking-donation-from-mackenzie-scott/" ><i class="fa fa-clock-o"></i> October 26, 2022</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_sm post-44729 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-upbeat-beat">
                <div class="jeg_thumb">
                    
                    <a href="https://yovenice.com/2022/10/26/96-year-old-del-rey-resident-writes-note-to-lafd-thanking-firefighters-for-assistance-after-fall/">
                        <div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://yovenice.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="96-Year-Old Del Rey Resident Writes Note to LAFD Thanking Firefighters for Assistance After Fall" data-src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-2.21.06-PM-120x86.png" data-sizes="auto" data-srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-2.21.06-PM-120x86.png 120w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-2.21.06-PM-350x250.png 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-25-at-2.21.06-PM-750x536.png 750w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">Left to right: Chuck Lorre, Gina Yashere, Liz Forer, Billy Gardell  Folake Olowofoyeku at Power of Us Event. Photo: David Crotty & Patrick McMullan via Getty Images.</span></div></div>
                    </a>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://yovenice.com/2022/10/26/96-year-old-del-rey-resident-writes-note-to-lafd-thanking-firefighters-for-assistance-after-fall/">96-Year-Old Del Rey Resident Writes Note to LAFD Thanking Firefighters for Assistance After Fall</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://yovenice.com/2022/10/26/96-year-old-del-rey-resident-writes-note-to-lafd-thanking-firefighters-for-assistance-after-fall/" ><i class="fa fa-clock-o"></i> October 26, 2022</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_sm post-44713 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-video">
                <div class="jeg_thumb">
                    
                    <a href="https://yovenice.com/2022/10/25/tour-the-ballona-creek-trash-interceptor-now-fully-operational/">
                        <div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://yovenice.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="Tour the Ballona Creek Trash Interceptor Now Fully Operational" data-src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-120x86.png" data-sizes="auto" data-srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-120x86.png 120w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-350x250.png 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-750x536.png 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/venice-_-brentwood-1-1140x815.png 1140w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">Left to right: Chuck Lorre, Gina Yashere, Liz Forer, Billy Gardell  Folake Olowofoyeku at Power of Us Event. Photo: David Crotty & Patrick McMullan via Getty Images.</span></div></div>
                    </a>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://yovenice.com/2022/10/25/tour-the-ballona-creek-trash-interceptor-now-fully-operational/">Tour the Ballona Creek Trash Interceptor Now Fully Operational</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://yovenice.com/2022/10/25/tour-the-ballona-creek-trash-interceptor-now-fully-operational/" ><i class="fa fa-clock-o"></i> October 25, 2022</a></div></div>
                </div>
            </article>
                </div>
            </div>
                <div class='module-overlay'>
                <div class='preloader_type preloader_dot'>
                    <div class="module-preloader jeg_preloader dot">
                        <span></span><span></span><span></span>
                    </div>
                    <div class="module-preloader jeg_preloader circle">
                        <div class="epic_preloader_circle_outer">
                            <div class="epic_preloader_circle_inner"></div>
                        </div>
                    </div>
                    <div class="module-preloader jeg_preloader square">
                        <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                    </div>
                </div>
            </div>
            </div>
            <div class="jeg_block_navigation">
                <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
                
                
            </div>
                
                <script>var epic_module_44736_0_63591e2c84098 = {"header_icon":"","first_title":"","second_title":"","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","number_post":"5","post_offset":"0","unique_content":"disable","include_post":"","exclude_post":"","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","process-categories":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":"20","excerpt_ellipsis":"...","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"5","pagination_scroll_limit":"0","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"epic_block_1"};</script>
            </div></div><div id="custom_html-7" class="widget_text widget_custom_html box mb-5"><h3 class="sidebar-title f-meta c-1"><span class="title">POPULAR</span></h3><div class="textwidget custom-html-widget"></div></div><div id="epic_module_block_13-2" class="widget_epic_module_block_13 box mb-5"><div  class="jeg_postblock_13 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 epic_module_44736_1_63591e2c85d73  normal " data-unique="epic_module_44736_1_63591e2c85d73">
                
                <div class="jeg_block_container">
                
                <article class="jeg_post jeg_pl_lg_1 post-44721 post type-post status-publish format-standard has-post-thumbnail hentry category-venice-beach-opinion">
                <div class="jeg_thumb">
                
                <a href="https://yovenice.com/2022/10/25/column-money-messaging-that-is-persuasive-and-memorable-may-just-make-rick-caruso-our-next-mayor/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://yovenice.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-350x250 size-epic-350x250 lazyload wp-post-image" alt="Column: Money &#038; Messaging That Is Persuasive and Memorable May Just Make Rick Caruso Our Next Mayor!" data-src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/caruso-bass-350x250.jpg" data-sizes="auto" data-srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/caruso-bass-350x250.jpg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/caruso-bass-120x86.jpg 120w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">Left to right: Chuck Lorre, Gina Yashere, Liz Forer, Billy Gardell  Folake Olowofoyeku at Power of Us Event. Photo: David Crotty & Patrick McMullan via Getty Images.</span></div></div></a>
                <div class="jeg_post_category">
                    <span><a href="https://yovenice.com/category/venice-beach-opinion/" class="category-venice-beach-opinion">Opinion</a></span>
                </div>
            </div>
            <div class="jeg_postblock_content">
                <h3 class="jeg_post_title">
                    <a href="https://yovenice.com/2022/10/25/column-money-messaging-that-is-persuasive-and-memorable-may-just-make-rick-caruso-our-next-mayor/">Column: Money &#038; Messaging That Is Persuasive and Memorable May Just Make Rick Caruso Our Next Mayor!</a>
                </h3>
                <div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://yovenice.com/author/nick-antonicello/">Nick Antonicello</a></div><div class="jeg_meta_date"><a href="https://yovenice.com/2022/10/25/column-money-messaging-that-is-persuasive-and-memorable-may-just-make-rick-caruso-our-next-mayor/"><i class="fa fa-clock-o"></i> October 25, 2022</a></div><div class="jeg_meta_comment"><a href="https://yovenice.com/2022/10/25/column-money-messaging-that-is-persuasive-and-memorable-may-just-make-rick-caruso-our-next-mayor/#respond" ><i class="fa fa-comment-o"></i> 0</a></div></div>
                <div class="jeg_post_excerpt">
                    <p>Moving away from direct mail, Caruso saturates broadcast television with a more disciplined message that is resonating with an angry...</p>
                    <a href="https://yovenice.com/2022/10/25/column-money-messaging-that-is-persuasive-and-memorable-may-just-make-rick-caruso-our-next-mayor/" class="jeg_readmore">Read more</a>
                </div>
            </div>
            </article>
            <div class="jeg_posts_wrap">
                <div class="jeg_posts jeg_load_more_flag">
                    <article class="jeg_post jeg_pl_md_1 post-44665 post type-post status-publish format-standard has-post-thumbnail hentry category-video">
                <div class="jeg_thumb">
                    
                    <a href="https://yovenice.com/2022/10/20/endless-summer-haven-on-the-sand/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://yovenice.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="Endless Summer Haven on the Sand" data-src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-10-at-12.24.22-PM-120x86.png" data-sizes="auto" data-srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-10-at-12.24.22-PM-120x86.png 120w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-10-at-12.24.22-PM-350x250.png 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-10-at-12.24.22-PM-750x536.png 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-10-at-12.24.22-PM-1140x815.png 1140w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">Left to right: Chuck Lorre, Gina Yashere, Liz Forer, Billy Gardell  Folake Olowofoyeku at Power of Us Event. Photo: David Crotty & Patrick McMullan via Getty Images.</span></div></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://yovenice.com/category/video/" class="category-video">Video</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://yovenice.com/2022/10/20/endless-summer-haven-on-the-sand/">Endless Summer Haven on the Sand</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://yovenice.com/2022/10/20/endless-summer-haven-on-the-sand/" ><i class="fa fa-clock-o"></i> October 20, 2022</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_md_1 post-44710 post type-post status-publish format-standard has-post-thumbnail hentry category-education category-news category-video">
                <div class="jeg_thumb">
                    
                    <a href="https://yovenice.com/2022/10/25/local-school-closed-after-water-and-mold-damage-parents-claim-neglect/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://yovenice.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="Local School Closed After Water and Mold Damage Parents Claim Neglect" data-src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-120x86.png" data-sizes="auto" data-srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-120x86.png 120w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-350x250.png 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-750x536.png 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/Screen-Shot-2022-10-19-at-11.19.48-AM-1140x815.png 1140w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">Left to right: Chuck Lorre, Gina Yashere, Liz Forer, Billy Gardell  Folake Olowofoyeku at Power of Us Event. Photo: David Crotty & Patrick McMullan via Getty Images.</span></div></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://yovenice.com/category/news/education/" class="category-education">Education</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://yovenice.com/2022/10/25/local-school-closed-after-water-and-mold-damage-parents-claim-neglect/">Local School Closed After Water and Mold Damage Parents Claim Neglect</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://yovenice.com/2022/10/25/local-school-closed-after-water-and-mold-damage-parents-claim-neglect/" ><i class="fa fa-clock-o"></i> October 24, 2022</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_md_1 post-44689 post type-post status-publish format-standard has-post-thumbnail hentry category-venice-beach-opinion">
                <div class="jeg_thumb">
                    
                    <a href="https://yovenice.com/2022/10/21/column-sparks-fly-at-south-brentwood-residents-association-council-forum/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://yovenice.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="Column: Sparks Fly at South Brentwood Residents Association Council Forum" data-src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/20221020_200115-120x86.jpg" data-sizes="auto" data-srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/20221020_200115-120x86.jpg 120w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/20221020_200115-350x250.jpg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/20221020_200115-750x536.jpg 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/20221020_200115-1140x815.jpg 1140w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">Left to right: Chuck Lorre, Gina Yashere, Liz Forer, Billy Gardell  Folake Olowofoyeku at Power of Us Event. Photo: David Crotty & Patrick McMullan via Getty Images.</span></div></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://yovenice.com/category/venice-beach-opinion/" class="category-venice-beach-opinion">Opinion</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://yovenice.com/2022/10/21/column-sparks-fly-at-south-brentwood-residents-association-council-forum/">Column: Sparks Fly at South Brentwood Residents Association Council Forum</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://yovenice.com/2022/10/21/column-sparks-fly-at-south-brentwood-residents-association-council-forum/" ><i class="fa fa-clock-o"></i> October 21, 2022</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_md_1 post-44692 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-venice-beach-real-estate category-video">
                <div class="jeg_thumb">
                    
                    <a href="https://yovenice.com/2022/10/24/new-39-unit-affordable-senior-housing-unveiled-in-santa-monica/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://yovenice.com/wp-content/plugins/epic-news-element/assets/img/jeg-empty.png" class="attachment-epic-120x86 size-epic-120x86 lazyload wp-post-image" alt="New 39 Unit Affordable Senior Housing Unveiled in Santa Monica" data-src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-120x86.jpg" data-sizes="auto" data-srcset="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-120x86.jpg 120w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-350x250.jpg 350w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-750x536.jpg 750w, https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2022/10/14-1140x815.jpg 1140w" data-expand="700" /><div class="ccfic"><span class="ccfic-text">Left to right: Chuck Lorre, Gina Yashere, Liz Forer, Billy Gardell  Folake Olowofoyeku at Power of Us Event. Photo: David Crotty & Patrick McMullan via Getty Images.</span></div></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://yovenice.com/category/news/" class="category-news">News</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://yovenice.com/2022/10/24/new-39-unit-affordable-senior-housing-unveiled-in-santa-monica/">New 39 Unit Affordable Senior Housing Unveiled in Santa Monica</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://yovenice.com/2022/10/24/new-39-unit-affordable-senior-housing-unveiled-in-santa-monica/" ><i class="fa fa-clock-o"></i> October 21, 2022</a></div></div>
                </div>
            </article>
                </div>
            </div>
                <div class='module-overlay'>
                <div class='preloader_type preloader_dot'>
                    <div class="module-preloader jeg_preloader dot">
                        <span></span><span></span><span></span>
                    </div>
                    <div class="module-preloader jeg_preloader circle">
                        <div class="epic_preloader_circle_outer">
                            <div class="epic_preloader_circle_inner"></div>
                        </div>
                    </div>
                    <div class="module-preloader jeg_preloader square">
                        <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                    </div>
                </div>
            </div>
            </div>
            <div class="jeg_block_navigation">
                <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
                
                
            </div>
                
                <script>var epic_module_44736_1_63591e2c85d73 = {"header_icon":"","first_title":"","second_title":"","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","number_post":"5","post_offset":"0","unique_content":"disable","include_post":"","exclude_post":"","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","process-categories":"","sort_by":"random_week","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":"20","excerpt_ellipsis":"...","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"4","pagination_scroll_limit":"0","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"epic_block_13"};</script>
            </div></div>    </div>
  </div>
          <!-- end -->
        </div>
      </div>
    <!-- end -->

  </article></div>
</main>


<footer id="footer" class="bg-black">
  <div class="container f-text py-5">
  
    <div class="footer-ad">
<!-- /21621973880/yovenice_footertop -->
<div id='div-gpt-ad-1598567470772-0'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1598567470772-0'); });
  </script>
</div>
</div>
  
  	  <div class="logo f-meta l-black pt-3 px-3 p-lg-0" itemscope="" itemtype="https://schema.org/Organization">
                                <div itemscope="" itemtype="https://schema.org/ImageObject">
                  <a href="https://yovenice.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="99" src="https://yovenice-enki.s3.amazonaws.com/wp-content/uploads/2019/08/cropped-yo-logo.png" class="custom-logo" alt="Yo Venice" itemprop="logo"></a>                </div>
                            <meta itemprop="name" content="Yo Venice">
            </div>

        <div class="f-meta text-uppercase"><div class="d-inline-block border-top border-bottom p-3  c-white l-white">
      <div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-35696" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35696"><a href="/">Home</a></li>
<li id="menu-item-38067" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38067"><a target="_blank" rel="noopener noreferrer" href="https://mirrormediagroupla.com/">Advertising</a></li>
<li id="menu-item-38068" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38068"><a target="_blank" rel="noopener noreferrer" href="https://mirrormediagroupla.com/">PR Services</a></li>
<li id="menu-item-38069" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-38069"><a target="_blank" rel="noopener noreferrer" href="https://mirrormediagroupla.com/#contact-us">Contact Us</a></li>
<li id="menu-item-35701" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35701"><a href="https://watchedify.com">Watch EDIFY</a></li>
<li id="menu-item-35700" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35700"><a href="https://yovenice.com/privacy/">Privacy Policy</a></li>
</ul></div>    </div></div>
        
              <div class="d-flex justify-content-center">
        <div class="w-social d-none h5 c-meta l-meta"><ul id="menu-social-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35478"><a href="https://www.facebook.com/YoVenice/">facebook</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35480"><a href="https://twitter.com/YoVenice">twitter</a></li>
</ul></div>      </div>
    
    <p class="m-0 pt-3 pb-4 f-text font-italic c-meta small">
      © 2021 Yo! Venice    </p>
    <p class="m-0 pt-3 pb-4 f-text font-italic c-meta small"> Made with ❤️ by <a href="https://enki.tech/">ENKI Tech</a></p>


  </div>
</footer>


</div>
</div>
<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script><script type='text/javascript' src='https://yovenice.com/wp-content/themes/balaton/assets/js/jquery.lazy.min.js'></script>
<script type='text/javascript' src='https://yovenice.com/wp-content/themes/balaton/assets/js/jquery.infinitescroll.min.js'></script>
<script type='text/javascript' src='https://yovenice.com/wp-content/themes/balaton/assets/js/jquery.sticky-kit.min.js'></script>
<script type='text/javascript' src='https://yovenice.com/wp-content/themes/balaton/assets/js/bootstrap.min.js'></script>
<script type='text/javascript' src='https://yovenice.com/wp-content/themes/balaton/assets/weart.js'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://yovenice.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.13-9993131'></script>
<script type='text/javascript' src='https://yovenice.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=99f6140c6ee020f39af35c3d1228b9e8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://yovenice.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=99f6140c6ee020f39af35c3d1228b9e8'></script>
<script type='text/javascript' src='https://yovenice.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var epicoption = {"prefix":"epic_module_ajax_","rtl":"0","admin_bar":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://yovenice.com/wp-content/plugins/epic-news-element/assets/js/script.min.js'></script>
<script type='text/javascript' src='https://yovenice.com/wp-includes/js/wp-embed.min.js?ver=99f6140c6ee020f39af35c3d1228b9e8'></script>
<script type='text/javascript' src='https://yovenice.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms.min.js?ver=4.8.3'></script>
</body>
</html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Content Delivery Network via Amazon Web Services: S3: yovenice-enki.s3.amazonaws.com

Served from: yovenice.com @ 2022-10-26 04:46:52 by W3 Total Cache
-->